Five9 extension update
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 09:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 13, 2020 - 15:20 EDT
Identified
Please try clearing cache and cookies for the Firefox browser, then refreshing the five9 window.

Relevant solution:

https://support.regent.edu/support/solutions/articles/4000006618
Posted Jul 13, 2020 - 09:13 EDT
This incident affected: Telephones (Phones).