MyRegent and CAS login issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 11, 2020 - 17:57 EST
Monitoring
The problem has been resolved. We are currently monitoring.
Posted Jan 11, 2020 - 17:46 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2020 - 17:03 EST
This incident affected: Identity Management and Logon Services (Central Authentication Service (CAS)) and Regent Websites (my.regent.edu).