MyRegent portal issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 13:57 EST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2023 - 13:27 EST
This incident affected: Regent Websites (my.regent.edu).