MyRegent portal down
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 11:05 EST
Investigating
We are currently investigating this issue.
Posted Nov 08, 2021 - 10:41 EST
This incident affected: Regent Websites (my.regent.edu).