Some users can't access DegreeWorks
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 08:42 EST
Investigating
We are currently investigating this issue.
Posted Feb 05, 2024 - 11:38 EST
This incident affected: Academic Services (Degree Works).