Office 365 Outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 09:22 EDT
Investigating
Microsoft has announced a major outage across its Office 365 Suite of products. They are working on resolving the issue. Regent IT is monitoring for Microsoft's resolution.
Posted Sep 28, 2020 - 19:32 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail) and Campus Services (Azure Dev Tools for Teaching).