Email Filtering Issue
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 08:44 EDT
Monitoring
A fix has been implemented to the external email quarantine issue from this weekend.
External messages should no longer be incorrectly quarantined.
Incorrectly quarantined messages from earlier should be arriving back in user inboxes throughout this afternoon.
Posted Oct 14, 2019 - 14:24 EDT
Identified
We are currently investigating an issue that caused external emails to be placed into digest for faculty and staff starting this weekend. We have located the root of the problem and corrected it. Incorrectly quarantined messages will be released over the next few hours.
Posted Oct 14, 2019 - 11:52 EDT
Investigating
We are currently investigating an issue that caused student emails to be placed into digest for faculty and staff starting this weekend. This is not normal behavior and should be resolved shortly.
Posted Oct 14, 2019 - 08:43 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).