Password Change Site Down
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 13, 2018 - 11:16 EST
Investigating
Password Reset is currently unavailable for anyone off campus.
Posted Nov 13, 2018 - 09:06 EST
This incident affected: Identity Management and Logon Services (Self Service Password Change).