MyRegent portal outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 13:16 EDT
Investigating
We are currently investigating this issue.
Posted Aug 29, 2022 - 13:14 EDT
This incident affected: Regent Websites (my.regent.edu).