Portal Access
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 16:59 EST
Investigating
We are currently investigating the issue.
Posted Feb 12, 2020 - 16:51 EST
This incident affected: Regent Websites (my.regent.edu).