Regent.edu invalid certificate
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 11:09 EDT
Investigating
We are currently investigating this issue.
Posted Apr 02, 2021 - 10:50 EDT
This incident affected: Regent Websites (regent.edu).