Inbound phone calls and campaigns not dialing out
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 12, 2020 - 12:40 EDT
Monitoring
The issues have been identified and resolved. We will continue monitoring for issues.
Posted Aug 12, 2020 - 09:11 EDT
Investigating
We are currently investigating this issue.
Posted Aug 12, 2020 - 08:53 EDT
This incident affected: Telephones (Phones, Call Center).