Blackboard Login for Students Down
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Nov 28, 2020 - 11:19 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2020 - 11:03 EST
Update
Thank you Regent Students and Faculty for your patience during this Blackboard Login and Enrollment outage. We are pleased to report that the Student login and enrollment issues appear to be resolved. We will continue to monitor the situation and please reach out to the Information Technology Help Desk if you continue to experience any difficulties.
Posted Nov 28, 2020 - 10:17 EST
Update
Thank you everyone for your patience with the Blackboard login issues that we are experiencing this morning.

We are seeing that some students are now able to login but are missing course enrollments. We are also working to restore proper course enrollments as soon as possible.

Please check back here for updates.
Posted Nov 28, 2020 - 09:14 EST
Investigating
Students are reporting that they are unable to login to Blackboard. Regent University IT is looking into the issue.
Posted Nov 28, 2020 - 06:45 EST
This incident affected: Blackboard and Learning Technology (Blackboard Learn).