The website apply.regent.edu is not letting applicants log in
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 14:39 EDT
Investigating
We are currently investigating this issue.
Posted Oct 19, 2020 - 08:35 EDT