Regent Portal
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Jan 11, 2020 - 08:33 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2020 - 15:41 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2020 - 15:12 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2020 - 15:11 EST
Update
We are continuing to investigate this issue.
Posted Jan 10, 2020 - 15:04 EST
Investigating
We are currently investigating the incident.
Posted Jan 10, 2020 - 15:02 EST
This incident affected: Regent Websites (my.regent.edu), Blackboard and Learning Technology (Blackboard Learn), and Academic Services (Banner and Genisys).