On Campus Phone Outage
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted May 15, 2022 - 20:01 EDT
Update
We are continuing to monitor for any further issues.
Posted May 15, 2022 - 15:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2022 - 15:18 EDT
Investigating
We are currently investigating this issue.
Posted May 15, 2022 - 13:21 EDT
This incident affected: Telephones (Phones).