Microsoft Office issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 08:03 EDT
Monitoring
An issue with Microsoft Office 365 has been identified that can affect not just Regent University but everyone that uses Office products. Please stay up to date at https://status.office.com
Posted Mar 15, 2021 - 18:04 EDT
This incident affected: Email (Faculty and Staff Microsoft Office 365 Outlook Mail).