MyRegent portal not loading
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Aug 24, 2022 - 19:08 EDT
Investigating
We are currently investigating this issue.
Posted Aug 24, 2022 - 16:59 EDT
This incident affected: Regent Websites (my.regent.edu).