Issues logging into MyRegent due to Duo
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Dec 15, 2021 - 11:10 EST
Investigating
We are currently investigating this issue.
Posted Dec 15, 2021 - 10:43 EST
This incident affected: Regent Websites (my.regent.edu) and Identity Management and Logon Services (Central Authentication Service (CAS)).