Five9 Issues
Incident Report for Regent University
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 08:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2021 - 14:19 EDT
Investigating
There are reports of degraded performance while taking phone calls. We are currently investigating the issue.
Posted Sep 29, 2021 - 09:19 EDT
This incident affected: Telephones (Call Center).